Jump to content

AndyC_67

Members
  • Content Count

    63
  • Joined

  • Last visited

About AndyC_67

  • Rank
    Member

Profile Information

  • Current Car
    330Ci Convertible

Recent Profile Visitors

966 profile views
  1. Yeah I had a feeling the whole thing would need to come off as they are direct in bumper rather than in a piece of trim. Do you know of any good guides how to do this....or should I just not be lazy and Google it myself??!! Thanks my friend!
  2. Hi I have a 2004 330ci convertible. It has the M Sport bumpers etc. One of the rear parking sensors is faulty. I scanned to see which one is faulty and it's the outer drivers side. When I select reverse there is a constant beep...even with nothing behind. The scan tool shows this one going full on straight away. (Odd as all 4 tick as they should). Anyway my question is whether or not they are removable without removing the whole bumper assembly? Any ideas? Thanks
  3. Hi there, I have same car (2004 330ci covertible) and I did my fuel pump last month. Took about 30min....and it only took that long as I couldn't find some snips to get the fuel pipe clip off the old pump. Especially easy with the conv. as you just drop the roof and you have loads of room to work.Oh and yes the pump is under rear seat on drivers side, just remove the cover plate and there it is. Car had similar symptoms you describe only getting worst then wouldn't start at all. I managed to get home the last time by getting someone to crank the engine whilst I knocked the fuel tank from under car.I think they just wear then the impeller gets stuck on a high spot...so knocking the tank dislodges the impeller and it can spin. Only worked once but I got home ok!! Phew! Good luck
  4. I'm pretty sure all the gearbox oils are "filled for life" but you don't have to look around for too long to find out that it's recommended to be changed at some point. I changed mine at around 120000 miles but I have read that every 100000 is about right. Whatever the case although the oil can be relatively expensive it's MUCH cheaper than a new gearbox!
  5. Unsure with the diesel but I have a 6 speed manual (petrol) and there were 2 plugs. The one underneath was drain and the one up the side (probably has a label next to it) is the fill. It was on the drivers side if I remember correctly.
  6. Hi there, I have a similar problem ....although when I put it in reverse I get a couple of beeps then a solid beep. I have disconnected the speaker until I get round to sorting it out (better weather!). The clicking is no real indication that the sensors are OK. I plugged the car into INPA and you can see all sensors individually working then one goes full on....so I know which one is faulty.
  7. Just a thought. Have you checked the connectors for corrosion & giving them a clean? I remember being told that and for some reason it actually worked for a while. It's free.....give it a go!!
  8. Perfect! Thank you very much for that. I have not done one of these before on a BMW. I take it there is only one thermostat or is this a special one? I'm used to thermostats being in the coolant line.....is it the same one? Sorry....I guess I could look it up...... Thanks again!
  9. Yes you are right both is recommended.....but costly. I was short of cash at the time and took a chance with the second hand one. What could have been expensive was fixed for about 15 quid. If you have the cash and you are getting fluid changed its probably best to do both.....it's your call really. Regarding both going wrong close together...that's assuming they were both fitted together I guess.....
  10. Yeah you do lose some fluid (can be minimised if you're quick on the change over!). No need to drain the fluid reservoir. Always best to bleed system after anyway. Oh make sure you put a rag under the sensor to stop getting fluid on you paintwork!!
  11. Good luck. If you are anywhere near Brighton give me a shout if you need it scanning! No charge (obviously!!)
  12. If you have the scanning software (inpa) remove one plug at a time from the sensor. At some point it will throw 2 errors then you can see which one is which....ie when you remove the plug from the good sensor. Takes 2min.
  13. Sorry just re read your post (doh!) I was just interested in the price of the part. Looks like the 250 is fitted. Took me about an 45min....and that was including tea!!
  14. Hi yes I have done this. Front one (I think that is sensor 1 but it's easy enough to check) ie the one nearest the headlights is easy....rear is harder to get to. Never seen them that expensive before. I was quoted about 100 plus vat from BMW. In the end I took a chance on a second had one from eBay. 18months on still perfect! Cost 15 quid!
×
×
  • Create New...