Jump to content
SPYMAN

Where is Flasher unit/Relay ?

Recommended Posts

My Sons W reg car has been off the road fora few weeks.

The battery went flat & he charged it up.

He's now having some weird happenings with his lights/indicators etc.

When he first mentioned it to me, I initially thought the flasher unit was on the blink (tho' I now gather it's a 'relay').

Q1/ Where do we find this relay ? It sounds like it's behind the instrument panel,,,, but before we start stripping, we'd like to know. I know they used to be (in my day) just under the lining above the footwell. Easy access - as they sometimes needed replacing regularly

When he called in last night, he informed me that:

sometimes he can hear the unit and the warning light flashes at the same time - but no indicators.

sometimes the indicators will flash, but not the warning light, nor - strangely - the relay isn't working (audibly anyway).

sometimes the headlights come on for no apparent reason

sometimes the warning light comes on - stays on, not flashing - even when the control is set to nothing.

Q2/ Would a less than great battery charge cause these symptoms ? He drove to work & back within a few hours of 150 miles, so should have got a decent charge (if the battery is in good nick)

Any other advice please ?

cheers

Share this post


Link to post
Share on other sites

I think it could be one of two things - first under the hazard light switch or second the relay itself which is in the glovebox next to the fuses if memory serves me correctly (which it does less and less these days).

Share this post


Link to post
Share on other sites

Thanks Mit,

We did look at the relays behind the glovebox,,,, but none of them seem to fit the bill. They certainly don't 'click' along with the flash.

Have looked in the E-box - same result.

I'll tell him about the Hazard swith tho',,,, makes sense to me.

cheers

Share this post


Link to post
Share on other sites

I can't remember where it is but apparently its blooming awful to get to. PM danw8986 as he told me where it is. In the pub. Naturally, I can't recall the info for the life of me :D

Share this post


Link to post
Share on other sites

make sure it's earthing correctly first,10mm nut behind the offside front headlight.

also there isn't a relay unit for the E46, it uses a light control module behind the light switch.

(I had a very similar problem)

Edited by BazzaB1971

Share this post


Link to post
Share on other sites

also there isn't a relay unit for the E46, it uses a light control module behind the light switch. Hi then you are saying that there is is no relay for the bmw 316i 2000 if it is behind the light swich how do you replace it or check it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...