Jump to content
_SYC_

Cars Died Again And Won't Start..... Fuel Pump?

Recommended Posts

Well after sorting out the issue last time just by adding fuel after spending 5 hours and £100 fitting a crankshaft sensor, it's done it again!!

Coming home last night the car started spluttering and a real loss of power. I got it home and went to go out later on and it started ran breifly and stopped, pressing the thriottle doesn't help either just cuts out.

Difference this time is I only just filled the tank so it can't have run out of fuel. So I'm thinking either the fuel filters clogged which acourding to BMW it's not a normal servicable part or the fuel pumps died.

I tried it this morning turning to P2 a couple times without starting and I can't hear the pump prime, turned it over and it wouldn't run at all. Had to come to work so haven' been able to look over it anymore.

I've heard that the relays go, does anyone know if that could be it? do you get those symptoms or does it just die outright?

BMW quoted me £75 for the fuel filter and £275 for a new pump.

On a seperate note I'm uing a lot of oil, dad said he saw a small amount of blue smoke when starting it the other day and theres some oil around the spark plugs, an ideas on this?

Any help would be great.

Share this post


Link to post
Share on other sites

sorry to hear that mate...i had the same problem and it turned out to be the fuel pump!

Edited by Mikey
Non Subscriber advertising

Share this post


Link to post
Share on other sites

The oil problem sounds like you have a leaking head gasket.

Not sure about the non-starting. I am guessing you've already done a diagnostic? If not, that should be your first port of call, as always.

Share this post


Link to post
Share on other sites

Definitely sounding like the fuel pump to me. My mates 325 had exactly the same symptoms and ended up needing to replace the fuel pump.

Share this post


Link to post
Share on other sites

sorry to hear that mate...i had the same problem and it turned out to be the fuel pump!

Cheers for the offer but can't wait for it to get here, so probably have to bite the bullet and buy one.

The oil problem sounds like you have a leaking head gasket.

Ah great, not good. I don't have any overheating issues or coolent issues so guessing it'd be oil to cylinder issue. How hard are they to do on these?

Share this post


Link to post
Share on other sites

They are a massive pain to do...

Share this post


Link to post
Share on other sites

IIRC its an 11.5 hours labour to change the head gasket.

Share this post


Link to post
Share on other sites

get a tester pen and see if you have powerr at the fuel pump.. then you know that the fuse, relay and wiring to the pump are fine

if you cant hear it priming then its gonna be either what ive just said or the pump.

if you have no power at the plug for the pump start with the basics - fuse

if the fuse isnt blown move onto the relay - replace or bypass for now then see if you have power

if stil no continuity test on the wiring :)

hope this helps!

Share this post


Link to post
Share on other sites

Cheers for the offer but can't wait for it to get here, so probably have to bite the bullet and buy one.

Ah great, not good. I don't have any overheating issues or coolent issues so guessing it'd be oil to cylinder issue. How hard are they to do on these?

No problem, if you need it pm and i get it to you asap....or try ecp they are half the price of the dealers

Share this post


Link to post
Share on other sites

Well it's all fixed.

Dug my way to the fuel pump, tested the cables to the pump and all fine, tested the pump and nothing. So new one in including new fuel filter just as a matter of course.

Cheers fo you help and suggestions guys

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...