Jump to content
Trevor

Eonon E46 Unit... Tips, Tricks And Questions

Recommended Posts

Feel free to contribute, will help others.

I needed to ask a question and thought a thread with everyone's questions and answers would help others.

My question is, there are two USB ports on the rear of my unit, but I can only get one to work at a time.

I thought both would operate and you would be able to switch between the two?

Tips, right angle GPS is a necessity, mine hasn't arrived yet and its been a proper toil.

If the screen is too bright at night, mine is, even on night mode. Pressing and holding the mute button is a shortcut to turning the screen off.

If you manually turn the unit off before switching ignition off, it restarts where it left off. Mine goes random if its turned off with the ignition and have read of others having same issue. Also affects steering wheel controls, all good if turned off manually.

Shafz has posted much further on in this thread a roundup so I have cut and pasted it here.

Thanks to Shafz.

So just to put all the tips in one post to make it easier for people (Trevor, you might might to update your first post with this)

If the screen is too bright at night, mine is, even on night mode. Pressing and holding the mute button is a shortcut to turning the screen off. There is also a moon icon in the top left hand corner you can press to turn the screen off

If you manually turn the unit off before switching ignition off, it restarts where it left off. Mine goes random if its turned off with the ignition and have read of others having same issue. Also affects steering wheel controls, all good if turned off manually. *UPDATE* someone has figured out a solution for the random bootup, thread is here http://forum.e46fana...34#post15617834

There are 2 USB ports on the back of the unit, but only one will work at a time. Also worth getting a right angled USB extenstion as there is not much space behind the unit when its pushed in all the way.

Also worth looking at a GPS receiver with a right angled connector, it is recommened but not essential as when you push the unit in, the cable can bend and break,

A good place for the GPS antenna is on the large flat part of the roof lining by the interior light/ rear view mirror facing the windscreen,

you can pop the interior light out, route the cable across the headlining and down the a pillar, and stuck the aerial on with a tiny bit of velcro tape. The aerial then has excellent signal and is totally out of sight. I personally have just put it on the metal bar behind the stereo, out of sight, and signal has been fine. Its better to test everything before slotting the unit in place

Hold finger on an icon on the home screen, e.g. ipod, then drag the icon to another icon e.g. cd player to replace it in the list...so essentially it swaps places

Pressing the R/T button on the steering wheel will change source on the unit

Press the volume button quickly and it'll go through

Volume.

Bass

Treble

Balance

Fader

iGo Primo 2 (at the time of writing this) is the commonly used nav system to use on this unit

Edited by Trevor

Share this post


Link to post
Share on other sites

Yes I have found that only one USB works at a time as well. Good to know about the mute button was not aware of it.

Share this post


Link to post
Share on other sites

Another tip I've come across.

Put your most listened to music on a USB stick rather than a micro sd.

Both work but the USB boots up a lot faster than the micro sd,

Edited by Trev1964

Share this post


Link to post
Share on other sites

A good place for the GPS antenna is on the large flat part of the roof lining by the interior light/ rear view mirror facing the windscreen,

you can pop the interior light out, route the cable across the headlining and down the a pillar,

i stuck the aerial on with a tiny bit of velcro tape.

the aerial then has excellent signal and is totally out of sight.

Share this post


Link to post
Share on other sites

Someone else was having that exact problem on here the other day, not sure if he found a solution.

My radio signal has been fine.

Waiting for my right angle GPS aerial to arrive and then gonna site it properly.

Mines dicky at the moment anyway, bent all out of shape by the heater box and the end hasn't stayed crimped on.

Ordered the right angle aerial as a solution.

Share this post


Link to post
Share on other sites

Volume is quite loud on 1-5 volume (not sure if its because iv got the HK system)

you can also turn off the screen by pressing the "moon" icon on the splash screen

Share this post


Link to post
Share on other sites

anyone know how to wire up the lighting with the side lights on the unit? The seller i bought mine off mentioned it can be done so it will light up with the lights even if the unit is not on

Share this post


Link to post
Share on other sites

Mine lights up with the rest of the dash.

Even when its switched off.

what year is your car? My main harness was the old style one so i had to use that adapter rather than the newer stye adapter - hence i am wondering with the newer adapter is the unit lights up and won't with the old style adapter?

Share this post


Link to post
Share on other sites

Mine is the later adapter I believe, round pins rather than flat...

thats probarbly why i think yours lights up with the dash.

Share this post


Link to post
Share on other sites

Sounds right.

Sounds like a wire is missing or in wrong place.

Simon who bought my stereo new said he had to swap two wires around cos they were in wrong spots in the plug...

Share this post


Link to post
Share on other sites

one thing i have noticed with mu unit is that when i am using the nav and it asks if you have reached destination - as soon as i hit yes and turn off the nav then it displays no signal on the nav and will not re-appear I have found until i unplug the harness which is a bit of a ballache! so the solution i have found is hit no instead of yes and then turn off and all is fine! my 1st unit did this as well. What about yours guys? do you have the same issue? i don't really tend to use the nav but for you who don't use it as well it may be worth checking this.

Share this post


Link to post
Share on other sites

I'll check that when the nav is up and running reliably.

Tried using it yesterday and the dodgy connection from my knackered GPS aerial made it dodgy, signal for a bit then lost it.

Share this post


Link to post
Share on other sites

I have really poor radio reception with mine, the std business set was spot on, does the std set have an amp built in that this new one doesn't? Or does it not power an external amp?

This may be a car issue rather than the aftermarket radio if you have two aerial connectors (Pre 01/2 cars) then the aerial amplifier ( passenger rear 1/4) will be missing one you can either fit a later aerial amp (must be 433mhz not 418 as its also the aerial for your alarm remote) or make a dedicated aerial amp which will give you a chance of getting dab etc

Share this post


Link to post
Share on other sites

android side not booting. sticks on black screen with android logo. any suggestions or experiences?

have you tried reseting it at the front?

Share this post


Link to post
Share on other sites

Came across another touch I was unaware of.

Driving yesterday and the unit was switched off, didn't feel like any music.

Got a phone call and the unit still took it handsfree.

Witchcraft!!

Share this post


Link to post
Share on other sites

Took the LCM out of my car for bungers to code.

Old lcm back in and has same issue mentioned in an earlier post on this thread.

Now the buttons don't light up with the car lights.

They light up fine when its turned on tho.

Also when I turn the lights on the stereo doesn't auto dim. It's set to auto in the settings and worked fine with the later lcm.

I'll check its back to normal when I get the lcm back and fitted.

Does look like a car issue tho and not a stereo problem.

If I didn't have the later lcm, I would have run a seperate wire from the bulb on the cig lighter so it worked properly.

Share this post


Link to post
Share on other sites

sorry but what is the LCM and how can it be wired to the cig lighter for it to work?

thanks

Share this post


Link to post
Share on other sites

sorry but what is the LCM and how can it be wired to the cig lighter for it to work?

thanks

LCM = Light control module

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...