Jump to content
The_Judge_

Sufs' 330d M Sport w/ SMG Paddleshift retrofit but otherwise generally falling apart body ....

Recommended Posts

It's not worth my time doing it myself either. I can get a quick flat down, fill and paint done to both arches for £2-300.. I'd rather pay that than do it myself.. BUT it's not even worth that to me! lol

Share this post


Link to post
Share on other sites

There's going to be a lot of them reaching this state about now as age catches up with them.

I found it quite liberating in a way when my old one got like this. I drove it into a wall trying to get it into the garage and damaged both doors. Who cares? I reversed it into a crash barrier (ironically) and damaged the rear bumper/smashed the rear light. Who cares? I used it as a test for arch rolling (rather than damaging a friend's good arches) and destroyed them. Who cares? Until it stopped starting and getting me to work and back, it was great just to bumble around in, not caring about it.

If I were you Suf, I'd either keep it running until it dies/the bill to fix it gets too big, or go to the other extreme and spunk some money on something lovely and new (and then watch it depreciate...).

Share this post


Link to post
Share on other sites

@TriggerFish - change your sig link :) put your e30 pic on flickr or a.n.other ... !

 

Just had a thought, anyone want to buy a set of alloys with winter tyres? I'll draft an ad ....!

Share this post


Link to post
Share on other sites

Meh... Let the world know photobucket ruined the internet. Greedy capitalist douches!

I've got winter wheels, but they need tyres... Yours are 18s though, aren't they?

Share this post


Link to post
Share on other sites

That said, I did update it anyway, and to a different photo too (from when I drove a friend to his wedding... ooooh! the excitement!)

Share this post


Link to post
Share on other sites

18s .... I'll be selling alloys + tyres most likely. We don't drive the car enough to justify them anymore I think

Share this post


Link to post
Share on other sites
On 30/12/2017 at 20:21, The_Judge_ said:

the car is now consistently failing to start intermittently, and occasionally the gearbox warning light comes on the dash and I think I 'may' have a dodgy injector. It's probably all fixable ...

Better than that, they all sound like symptoms of a dodgy battery. Mine had low battery charge which caused the gearbox warning to illuminate.

I wonder if your new HU is draining the battery...

Share this post


Link to post
Share on other sites
5 hours ago, dontpannic said:

Better than that, they all sound like symptoms of a dodgy battery. Mine had low battery charge which caused the gearbox warning to illuminate.

I wonder if your new HU is draining the battery...

I wish it was that easy ... I was getting these problems for some time just never updated this thread at the time. I originally thought it was glow plugs or worse the gearbox, I asked John at motologic to have a look and let me know if it was the end for the car! That was back in November and we changed the battery then for a brand new one. This gave me short term hope that the car wasn't having any serious problems.

Sadly, the issue came back here and there. I'm pretty sure the gearbox itself is ok and indeed it is something electrical but I'm just going to monitor it for now. As I only fitted the new HU a few days ago but had the problems since November, I have to think it's probably unrelated.

I went back to Diamond Alloys today to get some bead seal applied to a leaky alloy, they repaired all the buckles last week and the car feels really good after that and does drive really well, so let's just see. In the meantime,  I've decided to keep the car till it dies and enjoy it till then.

38595699255_6bb3cde963_b.jpg

38595697005_f4822d1d58_b.jpg

Edited by The_Judge_

Share this post


Link to post
Share on other sites

So I've been trying to get to bottom of the non-starting issues ... after youtubing and googling it came down to possibly glow plugs & relay (these have been sh*t) since I've owned the car so I dismissed this, fuel pump failure (I was hoping it wasn't this), fuel filter (mine was really rusty and it turned out I hadn't replaced it since May 2014 - 30,000 miles ago), or the fuel filter fuse.

After watching the youtube vidoes for the wrong type of 330d (later model I assume) I removed these fuses in the engine bay:

39510569782_7a3bfa591e_k.jpg

27764174369_13b665e678_k.jpg

38831435854_bd19a584c1_k.jpg

39510582082_66e89d4399_k.jpg

 

 

 

and found they were all working. I then tested the real fuse in the glove compartment and that was fine. So I then tackled the fuel filter:

38831357694_ffab028809_k.jpg

38831357274_905eaf0110_k.jpg

I'm not sure if it has fixed the non-starting issue (it was intermittent) BUT the car is awesome(r) to drive again :) I got a little carried away un my tests:

 

 

 

Edited by The_Judge_

Share this post


Link to post
Share on other sites

Oh yes, fuel filter is essential on diesel cars!

So many people I know just don't replace them (especially when they service the cars themselves) and are then amazed when they finally do. lol.

I follow the recommended service intervals on mine so get the fuel filter replaced every 2 services (Inspection 1).

Run it on vPower diesel for a few tanks too - that'll help clear it up a little.

Share this post


Link to post
Share on other sites

So, non starting issue is still there .... :( Quite intermittent, was an issue first thing in the morning, then fine for next few starts, then I almso got stuck at the local dump, then it was fine for the next few, then I almost got stuck at my brothers ...

 

It''s sending me a message .....!

 

 

Share this post


Link to post
Share on other sites

Can you get it on INPA when it's not starting? See if the values all look normal?

Alternatively, the trick I found for mine was unplugging the fuel rail pressure sensor would allow it to eventually falter into life. Might be worth trying, as it would point to a problem with the fuelling causing the non-start, rather than anything else like a cam/crank sensor...

Share this post


Link to post
Share on other sites

Nice to see you still got this Suf and you got the bottom of your starting problem. Always rewarding when you trying figure out a fault and then find the answer and it works. :)

Share this post


Link to post
Share on other sites
On 08/03/2018 at 21:37, DJ Syxx said:

Nice to see you still got this Suf and you got the bottom of your starting problem. Always rewarding when you trying figure out a fault and then find the answer and it works. :)

It (the car) is surviving, just :)

Share this post


Link to post
Share on other sites

WOW, that's a nasty looking old fuel filter. I replaced mine on my petrol 330 coupe the summer before last and although some of the pipes were deteriorating (and leaking) hence the reason for replacing the actual filter didn't look too bad at all. Still glad I Changed it, its a cheap part and a simple job so why not.

As mentioned, good to see your still running your E46.

Share this post


Link to post
Share on other sites

Not updated this for sometime! 

Been settling into new job and had some construction work at home, got screwed over by a builder, including him possibly reversing into my car door (no proof though). I then also damaged the lower trim because I drove into a friends hidden low wall in his driveway on a dark rainy day. Can't be bothered really fixing either, may try and repair myself one day.

Car is still chugging along though ...

IMG_20181024_080328.jpg

IMG_20181024_080337.jpg

Share this post


Link to post
Share on other sites

Anyone still on this forum??

 

So, I've decided to sell my car :( Still drives really well, phenomenal in fact. However I just can't bear to fix even minor things anymore, don't have the time or inclination. Watch this space on ebay for more details ...!

Edited by The_Judge_

Share this post


Link to post
Share on other sites

Shame that mate, after all you’ve been through with it. I’ve had my 330ci nearly 5 years now, keep thinking about selling but just can’t find anything anywhere near the condition of it. I’ve got the cam cover gasket and oil filter housing gasket to change next week, I use it daily now and I love driving it. Any thing in mind what’s next?

Share this post


Link to post
Share on other sites
11 hours ago, gaz-777 said:

Shame that mate, after all you’ve been through with it. I’ve had my 330ci nearly 5 years now, keep thinking about selling but just can’t find anything anywhere near the condition of it. I’ve got the cam cover gasket and oil filter housing gasket to change next week, I use it daily now and I love driving it. Any thing in mind what’s next?

Yeah, it was tough, but it's now gone, it got picked up earlier for next to no money! What disappoints me is when I search for a new car with the same or equiv bhp, you end up having to spend decent money or accept another 'elderly' car. I'm looking for low maintenance car, looks good, but can match on power.

I'm in no rush to get a new car, but if I do it will be petrol. If I try to keep spend reasonable I may get a 135 (or higher), otherwise if I take a big loan then maybe an X1 as apparently they are just E90's behind the scenes right? They're only 4 cylinder 2.0 litre engines (so tax seems low)  but the super charger gives enough oomph in hp. 

The idea though of spending all that money ....... :(

Share this post


Link to post
Share on other sites

Sad to see another Zoner selling up. It is starting to get lonely on here sometimes.

Enjoy whatever you go on to buy though. 

Kirkynut 

Share this post


Link to post
Share on other sites
On 28/04/2019 at 17:45, The_Judge_ said:

Anyone still on this forum??

 

So, I've decided to sell my car :( Still drives really well, phenomenal in fact. However I just can't bear to fix even minor things anymore, don't have the time or inclination. Watch this space on ebay for more details ...!

Ahhh Suf, sad times! I know exactly where you are coming from. Not sold mine yet, but it could well be this year - not driven it for a while and I'm now burning around in a c. 400bhp M140!

Share this post


Link to post
Share on other sites

 

On 13/05/2019 at 21:39, JasonK said:

Ahhh Suf, sad times! I know exactly where you are coming from. Not sold mine yet, but it could well be this year - not driven it for a while and I'm now burning around in a c. 400bhp M140!

I was so tempted to do something similar Jason, the bhp from these  big engine1 series' looks amazing, I'll have to get a test drive at some point!

In a completely impromptu move, I've bought a Merc, it's a low mileage W204 - aka C280, 3.0 litre. Drives well, 234hp, but the upgrade mod scene is not as fun - I thought I could install a retrofit android unit. Turns out I would have to splash out a lot of money for a big 11" android - so I'm not going to bother.

Edited by The_Judge_

Share this post


Link to post
Share on other sites

I'm pretty sure my beemer head now been stripped or exported by its current owner, don't think they kept it. Still miss it, I'm now only appreciating the handling improvements things like poly bushes etc made 😭

 

Anyway, this is me now: https://forums.mbclub.co.uk/threads/sufs-w204-c280-saloon.251408/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...