Jump to content
Sign in to follow this  
Chrishawker86

So car broke down this morning

Recommended Posts

Annoyingly it cut out on me on the way home after a long night shift literally 5 minutes walk from my home, I pretty much knew what it was from the way it cut out, and my suspicions were correct when i plugged it in and saw that the air flow meter had failed. What was surprising is that this was only replaced last July with a new part from GSF which cost £120. Would this part still be under warranty? I've not had chance to call as they were closed. Has anyone experienced MAF's failing so quickly?

Edited by Chrishawker86

Share this post


Link to post
Share on other sites

Always possible,everything is mass produced ,poorly made or substandard part can always slip though,I've had bulbs, ,battery's,crank sensors,plug leads all knackered out the box,aftermarket rotors which break down after a few days ,ive had new rebuild engines let go on the dyno for now reason other than they just went bang.

Have a word with supplier they may have had others die ,let them know and how many miles you have covered and how long you've had it fitted,you never know they might be nice and do a deal on replacement ,if ya don't ask you don't get

Share this post


Link to post
Share on other sites

Can't see why the car would stop with a faulty MAF, limp home mode yes but not stop, I've had mine running with the MAF completely disconnected.

Share this post


Link to post
Share on other sites

As above, it's probably the pipe work leading to the MAF

Share this post


Link to post
Share on other sites

GFS don't do original parts there all cheap copys I work 40 feet away from the shop they are over priced and crap from there .I got a egr valve from there and still had the same fault as before I put it on told them and as I guest it was a copy..lol

guess you know my feelings about them..

Share this post


Link to post
Share on other sites

Can't see why the car would stop with a faulty MAF, limp home mode yes but not stop, I've had mine running with the MAF completely disconnected.

Yea the car starts when its disconnected first thing i did when i opened the bonnet but runs rougly

GFS don't do original parts there all cheap copys I work 40 feet away from the shop they are over priced and crap from there .I got a egr valve from there and still had the same fault as before I put it on told them and as I guest it was a copy..lol

guess you know my feelings about them..

Yea think ill try source a second hand OEM part for now

Edited by Chrishawker86

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...