Jump to content
berts

Berts' 330i SE

Recommended Posts

yesterday took advantage of the first bit of sun this summer and resprayed the mv2 alloys i bought, not the best job struggled a bit been a bit colour blind trying to see what bits i was spraying but main problem was my lack of patience and rushing the job. for a quick make over they are okay, now i will save up to get them done professionally

in primer

20150721_150709_zpsbzyopkn0.jpg

20150812_121045_zpsl6pysnnv.jpg

20150812_121109_zpsknk2xqdz.jpg

20150812_150607_zpscnrqk1qb.jpg

Edited by berts

Share this post


Link to post
Share on other sites

The oil warning light came on the other day so after a quick look under the bonnet the car seemed to be leaking oil from the rocker cover seal

20150830_234137_zpsujbn5wxh.jpg

so decided to changed the seal, and also took advantage of taking the top of engine off and fit the post cat oxygen sensor

20150902_154322_zps5sjlf6p9.jpg

really struggled to remove sensor due to it been so rusty after 6 hours of off and on trying to remove it ( doing rocker seal same time ) i got it off but broke the wire in the mean time, anyway went to fit new one only discover i had ordered the wrong one so had to put the old broken sensor back to plug up the exhaust. now need to return wrong part and then order the correct one

Edited by berts

Share this post


Link to post
Share on other sites

done a couple of updates today, headlight warning light was on so took the opportunity to change all 4 bulbs for more powerful ones i had in my old headlights from my old car

5BC9E613-9898-4A6D-8D77-043E8DEDD83E_zps

also decided to finally get round to fixing the common poor earth on the rear lights, saw this guide on here http://www.e46zone.com/forum/topic/25287-rear-light-cluster-warning-lights/and thought it looked easy, but ran in to a problem that my rear light didn't have a metal piece to clip the earth on to so had to improvise so i soldered a connector on myself

1B359013-9AFB-49CE-91A6-0767DF808AA5_zps

716B2CAE-5046-4BFD-A3D4-752CD3D83A26_zps

next problem car seems to be losing oil so need to search for where it is coming from

Share this post


Link to post
Share on other sites

Thank you for the info on the poor earth to the rear lights. It looks like I've got that issue too so will resolve it in the morrow!

Kirkynut

Share this post


Link to post
Share on other sites
okay decided to step up my game and gave the car a good clean that it desperately needed
before
IMG_0043_zps9je8rvx6.jpg
IMG_0045_zpscns4egzo.jpg
IMG_0054_zpsvoeh1bbc.jpg
IMG_0059_zpstu7k3zab.jpg
Snow foam
IMG_0061_zps6hfzs16e.jpg
after Polish
IMG_0063_zpsxtltlxkt.jpg
New badge
IMG_0064_zps2xfdmqwa.jpg
finished result
IMG_0067_zpsok4l95wj.jpg
will have to wait until tomorrow to get a decent picture as it was getting dark by the time i finished

Share this post


Link to post
Share on other sites

Started to replace the CCV and Disa valve today after waiting ages for some dry whether
first ive bought some axel stands and a new jack to carry out the work and for future jobs

14326975-9A4A-4080-9D75-394CFB785A45_zps
55B4B627-D03B-4197-9D2F-69D99F5BE605_zps

so far ive taken off air filter and housing, intake sleeves ( found two cracks in them ) dipstick and disa valve but had to stop due to it getting dark, hope to carry on Tuesday

D738BB61-7638-44D3-BF96-D2BBA2926DC8_zps
BD15C6A6-0E84-4B57-B7C6-CC7DBE6B3783_zps 
 

Share this post


Link to post
Share on other sites

Not much more, throttle body is off and cleaned icv ( not needed to replace ccv ) got old ccv out. Had a quick go at fitting new ccv but the top fitting is very hard and I didn't have much time

look on YouTube for guides, just type in e46 ccv and there should be one by "bulls**tkorner" that's the one I'm using for guidance

16 minutes ago, avalaugh said:

Any further ?

 

Going to start to do mine tomorrow.

 

 

Sent from my iPhone using Tapatalk

 

Edited by berts

Share this post


Link to post
Share on other sites

Still doing bits when i get a free hour or two, managed to do hard part of job and connect top hose on ccv. hoping weather improves so i can put everything back together next tuesday
67AECC50-0316-4569-9523-F940789E4E30_zps

and the icv and throttle body in need of a clean
261C08B2-2DD2-4066-8210-6B6B2CD43652_zps
DEC20FE4-2E2A-41DA-8420-BEB1C2371FF9_zps
5E0E8032-2A5D-4376-BEE6-ED1723D90C56_zps

Share this post


Link to post
Share on other sites

still bad weather and have been working. managed to fix disa valve and put new o ring and changed o ring on throttle body
176F427E-3F4B-4D61-9C14-2025BB65AC8F_zps

Share this post


Link to post
Share on other sites

Quick update - after doing the ccv the car developed a missfire, after changing spark plugs, air filter and cleaning maf still didn't run right so took it to garage yesterday to get the live data read but there was nothing there to say what the problem is, so it must be a vacuum leak somewhere so got to pull it apart to have a look when I get the chance

Share this post


Link to post
Share on other sites

Quick update - after doing the ccv the car developed a missfire, after changing spark plugs, air filter and cleaning maf still didn't run right so took it to garage yesterday to get the live data read but there was nothing there to say what the problem is, so it must be a vacuum leak somewhere so got to pull it apart to have a look when I get the chance

Share this post


Link to post
Share on other sites

Could be one of the plugs that goes into your spark plugs... Think they are called ignition coils when you search for them.... I had same problem last year when my car was misfiring... Ended up being the third one.... 

Share this post


Link to post
Share on other sites
7 hours ago, J15 CJY said:

Could be one of the plugs that goes into your spark plugs... Think they are called ignition coils when you search for them.... I had same problem last year when my car was misfiring... Ended up being the third one.... 

Thanks but I've tried moving around coil packs around but the misfire doesn't move cylinder with the coil pack 

Share this post


Link to post
Share on other sites
7 hours ago, J15 CJY said:

Could be one of the plugs that goes into your spark plugs... Think they are called ignition coils when you search for them.... I had same problem last year when my car was misfiring... Ended up being the third one.... 

Thanks but I've tried moving around coil packs around but the misfire doesn't move cylinder with the coil pack 

Share this post


Link to post
Share on other sites

nothing really to update my baby has just been born so not much time at moment to fix but have a couple of weeks off later in the month so will have a go then

also wife got me a present for valentines day
1F239238-0B94-4341-A3C1-5768878A0737_zps

so when the weather dries up and car runs again ( and passes mot in march ) i will give it a proper clean and wax

Share this post


Link to post
Share on other sites

managed to find time to have a look at my car, started to pull off manifold and noticed a vacuum pipe was off at the back so replaced it and put engine back together thinking that was the problem but took for test drive but the misfire was still there but a little better then it was, so next day pulled the manifold off completely 

while i was doing this i noticed another vacuum pipe was off (the one circled in red in picture)

manifold_zpsejpsghhp.jpg

ordered a new gasket today as the old one was hard and brittle, so hopefully when i put everything back together the car will be fixed and back to normal, fingers crossed

F4A74E8A-8A3B-4332-AC6B-5B6FC99DADB5_zps

Share this post


Link to post
Share on other sites

finally got to the bottom of the vacuum leak, it was the pipe i had spotted. its the vacuum pipe that comes from the bottom of the manifold and goes to the Evap purge valve (fuel tank breather valve ) don't remember pulling off when i took things apart

changed the gasket and put it all back together today, ran it up to temperature and no misfire appeared. unable to take for test drive as its declared SORN at moment booked in for MOT on Thursday so hopefully will pass and i will tax and be back on road by next week

Share this post


Link to post
Share on other sites

Finally got round to give the car an oil change been meaning to for last 6 months but not had chance been a bit crazy few months. ive owned the car for an year and a half now and supposedly it got serviced before i got it but judging by the state of the oil filter i think the garage lied to me :-/ as ive only done 7k since i bought it so it should look that bad
D7C4A91C-0AAC-474F-923C-8CBCD0DE325A_zps

Share this post


Link to post
Share on other sites

time to update this again,last Wednesday car went in for mot and failed on the following :-

Reason(s) for failure
offside Front suspension has excessive play in a lower suspension ball joint (2.5.B.1a)
nearside Front suspension has excessive play in a lower suspension ball joint (2.5.B.1a)
offside front inner Suspension arm rubber bush deteriorated resulting in excessive movement (2.4.G.2)
nearside front Front position lamp(s) not working (1.1.A.3b)
nearside front Windscreen washer provides insufficient washer liquid (8.2.3)

Advisory notice item(s)
nearside front inner Suspension arm rubber bush deteriorated but not resulting in excessive movement (2.4.G.2)
offside front lower Anti-roll bar linkage ball joint dust cover deteriorated, but preventing the ingress of dirt (2.4.G.2)
nearside front upper coil spring corroded (2.4.C.1b)
nearside rear lower coil spring corroded (2.4.C.1b)
offside rear lower coil spring corroded (2.4.C.1b)

so as i don't really use the car at the moment as have a b class as family car and wife hasn't passed her test yet so im going to take the bmw off the road and save money by repairing it myself and in the mean time save money by not paying tax and insurance. but might leave it till weather is a bit warmer

2C9AC03E-F9AD-4CAB-810B-211F2C54131C_zps

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...