Jump to content
Buzz

No sound from new headunit !!

Recommended Posts

Hi lads

ive purchased myself a new xtrons unit fro xmas as it has dab etc,seems a great little unit but i have no sound at all ..................

checked evrything,settings etc,plugs but still nowt.

 

I plug my old unit back in and sound straight away,could it be a unit fault ??

I have harmon kardon but surely that cant make a difference,no subs or rcas are connected either

 

thanks in advance.

 

:/

Share this post


Link to post
Share on other sites

Check power from headunit to HK Amp, do you get sound on radio.

Known issue with some looms is that the amp does not get a 12v switch live from the headunit

Sent from my LG-H815

Share this post


Link to post
Share on other sites

Post a pic of the loom up mate, a pic of the unit also from interest as it has dab

Sent from my LG-H815

Share this post


Link to post
Share on other sites

thanks chimp but sorted it.

on the loom there was an antenna wire and i plugged that into the blue antenna from dab which caused a sound loss somehow,disconected and works fine.

DAB works really well and has good sound quality from the unit 

im happy now :D

 

Edited by Buzz

Share this post


Link to post
Share on other sites

Oooo im just about to purchase this unit from the same seller. Good to hear the dab works well. Where did you mount the aerial?  

Share this post


Link to post
Share on other sites

I have a similar issue. 

Xtrons Unit on for my 2003 E46. 

No HK. 

Everything works aside from sound. There are zero remaining cables from Car Loom side. 

What do I need to do to get sound? 

Thanks, 

Chris 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...