Markus5000

Weird noise when turning hard left

5 posts in this topic

Hi all. Bit of a lengthy post but please bear with me. 
I've been getting an odd noise when I turn left hard. Its like a staccato noise that disappears once I've straightened up. I've jacked up the front end and done the usual wiggling of front wheel to see if there's bearing play but there's none.
I've been looking at some YouTube vids of abs ring probs and going by the staccato noise, when under load, I'm wondering if the abs sensor is contacting the ring. Now presumably this would only happened if there was excessive play in something that stops horizontal motion. Any ideas? Ta all :)

Share this post


Link to post
Share on other sites

Sam   

Is it not something simple like trim rubbing on full lock? granted a different car, but my air ducts came loose and I got a horrible noise on full lock

 

Share this post


Link to post
Share on other sites

Thanks for looking sam. I don't think its rubbing, had a look and no evidence of this. Only seems to happen when under power in the turn. So only when under load. I tried to get it to do it when driving it with Jo (triggerfish) but sods law, wouldn't do it lol. It seems easier to make the noise now so whatever it is, its got worse

Share this post


Link to post
Share on other sites
Beatbox   
Thanks for looking sam. I don't think its rubbing, had a look and no evidence of this. Only seems to happen when under power in the turn. So only when under load. I tried to get it to do it when driving it with Jo (triggerfish) but sods law, wouldn't do it lol. It seems easier to make the noise now so whatever it is, its got worse
What kind of noise is it you are getting? Is it like a creaking at all? I had a similar problem when turning left sometimes before.. Turned out to be the lower arm ball joint! Just a thought pal!

Sent from my F8331 using Tapatalk

Share this post


Link to post
Share on other sites
18 hours ago, Beatbox said:

What kind of noise is it you are getting? Is it like a creaking at all? I had a similar problem when turning left sometimes before.. Turned out to be the lower arm ball joint! Just a thought pal!

Sent from my F8331 using Tapatalk
 

Thanks man. Its not so much a creak but like I've driven on a rumble strip until I straighten the wheel again :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now