Jump to content
Sign in to follow this  
MICK 330

330Ci trembling/shaking at idle on start up Any ideas?

Recommended Posts

Hi Chaps,

As title really.....Drove 100 miles with no probs then next morning.....Started up the old gal & it fired up as usual but then began to shake/Tremble/vibrate whatever you wanna call it lol. Sat there let it run but nowt changed. Took it out down the road 100 yds juddering through the steering wheel to the junction, still doing it. 500yds till next stop still doing it so still a cold engine. After 1 mile got to the next junction & temp gauge now at say 10/11 oclock she was fine. Ran ok all day.... then today started it up this morning & runs sweet as a nut! I know ive gotta get codes read but I like to go to the indy with half an idea so I know he aint full of BS with his diagnosis lol. Any ideas gents??

Share this post


Link to post
Share on other sites

Did it feel like it was running on all 6cyl? Was it spluttering along? Or was the vibration from the drive line, hindering its ability to move?

Share this post


Link to post
Share on other sites

Hi Momo,

Yeah sorry I should have worded it better! The vibration is only when its stationary at idle & the engine is cold mate.

TBH I cant tell as its bad, but you have 6 when you rev it. I know its not drive line as it does it from start up stationary. It kind of clears on drive off (no spluttering)100yds to our junction but when stationary there the steering wheel vibrates car shakes etc again. When its out of the blue/cold section of the temp gauge it clears. There is a idle valve on these things so wondering if its that but its only when the engine is cold....so far lol

Thanks for racking your brains!

Share this post


Link to post
Share on other sites

Tbh mate i've not got a clue about these petrol engines. I know a few things about them, but not much. More of a diesel person! lol.

I saw something similar years ago with an E36 328i I once looked at buying but I walked away.

Sounds like it could well be the ICV. Apparently they can be cleaned? But then again it could be coils, it could be plugs or even VANOS!

Hopefully this info is enough for someone more knowledgeable to offer some advice..

Edited by momo

Share this post


Link to post
Share on other sites

Need to read codes tbh but could be anything, Coils, camshaft sensor going bad, ICV,  Maf , leak in intake hose? Few starters for you 😎

Share this post


Link to post
Share on other sites

Nothing on codes lol Sods law! Intake hoses are months old & ok. Maf is ok. 

2 x 330`s & neither of the buggers will tell a computer whats wrong with them!!!!!! :mad::mad:

Share this post


Link to post
Share on other sites

I have had mine do this a handful of times before all in cold weather except mine only done it while on the cold start so as soon as the revs drop to normal idle it would be fine again. Only once did a light come up and that was when i pressed the throttle and it miss fired on one cylinder. 

A good service fixed mine for a few years until i had done a long journey in the rain and parked it for a week in freezing temperatures, started it up and was missing on all cylinders for a few minutes but soon cleared.

I think it is a more common thing then you think i remember reading something about the cause but can't for the life of me remember what it was but its something todo with the cold start system on the m54.

Share this post


Link to post
Share on other sites

Thanks for reply R11CH,

It hasn't done it since lol. Cold weather is coming so see if it re appears. My 330d is playing up weekly (fueling issue which man computer nor beast can bloody find)so I could do without the Ci bleeding me dry too. Sounds like I can ignore the shaking for a while when/if it returns. Here`s hoping lol:unsure:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...