Jump to content
Splondike

DSC, Handbrake and ABS lights on and Speedo not working

Recommended Posts

Hi all, my little track hearse is playing up.  I have not used it for about 4 weeks as I have been unwell, went out yesterday and have the DSC, Handbrake and ABS lights are on and speedo not working.

I have had a read up and I know the wheel sensors can cause this ( they were renewed a few months ago and no issue until now ).  Also I noticed the blue and yellow wire in the second picture is not connected to anything, could this be related ? as I have not noticed it being adrift before.   (before I start removing wheels and checking sensors)

 

Thanks in advance for any assistance :)

 

dash.jpg

wire.jpg

Edited by Splondike

Share this post


Link to post
Share on other sites

Thanks, so you don't reckon the wire has anything to do with it?  Ok, what about the passenger side rear wheel sensor, I thought that could cause what I am seeing, including lack of speedo ?

Edited by Splondike

Share this post


Link to post
Share on other sites

A code reader is a lot cheaper than throwing random parts at the car. The chance of the internet people knowing what the wires are for is very low. So you will have to go find the wiring/circuit diagrams and read them yourself.

If the speedo was working 4 weeks ago, and you didn't cut the wires yourself in the mean time, then the wires can't be responsible for the speedo problems.

Share this post


Link to post
Share on other sites

A cheap £5-£10 inpa reader is all you need. Since china is out of action currently, you should go for a local stock seller and pay a bit more. Don't go for a generic reader, it will be useless. To use it, you'd need a laptop, or windows tablet.

Edited by E46Driver330Ci

Share this post


Link to post
Share on other sites

If you own an E46 the best investment you'll ever make is INPA.

I've had my trifecta of lights on the way back from work yesterday, plugged my INPA cable in and got the exact error within seconds.

IMG_1457.jpeg

Share this post


Link to post
Share on other sites

Ok I've ordered one from UK with cable etc.  I am fairly IT literate so hopefully will be ok. Guess it will be handy for the E36 too, not so much for the E28 :)20180624_172723.jpg.3923ae0acc138e69d14e9344303c565d.jpg20180624_172611.jpg.330c82a13de599401d12bdec9f5fe01d.jpg

Share this post


Link to post
Share on other sites

Both rear ABS sensors had been replaced recently (with cheap and nasty ones).  So I removed and cleaned out the hubs with brake cleaner and an airline.  This brought the speedo back to life but lights still on.  I bought a new sensor for the drivers side from BMW and replaced it and now all it back to normal.   So buy cheap, buy twice as most of us know.  I would not have put cheap and nasty ones on myself but hey ho its working now.

 

Next to replace the cheap and nasty throttle cable that was also renewed at the time as  the sensors and has also broken off at the pedal end !  Will get one from BMW when they re-open.  Next to install the harness bar and carry on with the weight loss program !

 

Stay safe everyone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...